Ankündigung

Einklappen
Keine Ankündigung bisher.

XP SP2 Bluetooth-Stack mit (fast) jedem Adapter - so gehts!

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • XP SP2 Bluetooth-Stack mit (fast) jedem Adapter - so gehts!

    Das Folgende ist eher eine theoretische Anleitung, d.h. WENN es funktioniert, dann so. Kann aber natürlich trotzdem sein, dass der eine oder andere Adapter mit dem BT-Stack von XP SP2 einfach nicht will.

    Also: Die Beta-Version des SP2 für XP (Download hier) beinhaltet bekanntlich nun endlich einen richtigen Bluetooth-Stack. Ich habe zwar noch nicht genau herausgefunden, welche Profile nun gehen, aber das serielle und das HID-Profil gehen auf jeden Fall schon mal. Ersteres sollte für die meisten Leute, die Handys via BT anbinden wollen, eigentlich ausreichen. Die Rumexperimentiererei mit der Widcomm-SW, die ja doch für das eine oder andere Problem gesorgt hat, sollte damit für Viele der Vergangenheit angehören. Wobei sich die XP-Implementation natürlich auch erst noch beweisen muss...

    Wie auch immer - momentan scheitern scheinbar viele User schon daran, ihren BT-Adapter mit den BT-Treibern von XP SP2 zur Zusammenarbeit zu bewegen. Die folgende Anleitung beschreibt, wie man THEORETISCH jeden Adapter zur Mitarbeit bewegen sollte. Praktisch kann es aber natürlich gut sein, dass der MS-Treiber halt mit einigen BT-Chipsätzen einfach nicht kann. Da aber die allermeisten BT-Adapter am Markt auf derselben Hardware basieren und sich nur durch die Device IDs unterscheiden (und genau deswegen hakt es ja bei der Installation), sollte es in den allermeisten Fällen funktionieren.

    Los gehts:

    Zuerst muß die Device ID des verwendeten BT-Adapters ermittelt werden. Hierzu geht man, BEVOR man irgendwas deinstalliert oder den Adapter abzieht, in die Registry. Um in der Registry nicht unnütz viel rumsuchen zu müssen, schaut man zunächst im Gerätemanager nach, wie genau das Gerät heißt. Dann geht man in die Registry und sucht nach diesem String. Bei mir heißt der Adapter z.B. "IBM Integrated Bluetooth II". Die erste Fundstelle in der Registry sollte in

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class

    sein. In dem Pfad, in dem der Name gefunden wurde, sollte es dann weiter unten den Wert "MatchingDeviceID" geben. Die ID beginnt auf jeden Fall mit usb\vid_, und komplett sieht sie so aus:

    usb\vid_xxxx&pid_xxxx

    Manchmal ist die ID etwas länger, geht dann mit rev_xxxx weiter. Dann so komplett verwenden.

    Falls es so nicht zu finden ist: Die nächste Fundstelle in der Registry sollte in

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB

    sein. In diesem Pfad hängen dann mehrere Unterpfade, deren Namen aus der Device IDs der verschiedenen USB-Geräte besteht, die man im Laufe des Lebens dieser Windows-Installation so angeschlossen hat.

    Nachdem man die ID notiert hat, entfernt man den BT-Adapter und deinstalliert die vorhandene BT-Software. Nach einem Neustart kann man SP2 installieren.

    Nach erfolgter Installation geht man nach c:\windows\inf und lokalisiert die Datei bth.inf. In dieser findet man die Sektion Device Section - Start. Dort fügt man jetzt, analog den bereits vorhandenen Einträgen, die ID des eigenen Adapters hinzu. Da die allermeisten Adapter am Markt auf dem CSR-Chipsatz basieren, dürfte man i.d.R. richtig fahren, wenn man den Adapter in der Sektion

    [Cambridge.NT.5.1]

    hinzufügt. Der Name des Adapters, den man hier einträgt, ist im Grunde wahlfrei; er erscheint dann halt später mit diesem Namen im Gerätemanager. Man kann einfach den Originalnamen nehmen (also den, den man oben in Schritt 1 aus dem Gerätemanager entnommen hatte).

    Nun noch nachschauen, ob Windows die INF-Datei bereits kompiliert hatte. Eine eventuell vorhandene bth.pnf löschen.

    Jetzt den BT-Adapter wieder anschließen. Und wie gesagt - THEORETISCH sollte er jetzt erkannt werden und der MS-Treiber sollte sich installieren. Erfolgskontrolle: Im Gerätemanager stehen unter Bluetooth-Funkgeräte zwei Einträge, nämlich der des eben modifizierten Eintrags, und eine Microsoft Bluetooth-Auflistung. Außerdem gibts in der Systemsteuerung ein neues BT-Icon.

    Viel Erfolg!
    Zuletzt geändert von BigBlue007; 24.03.2004, 17:20.

  • #2
    Die Anleitung funktioniert, wenn es auch eine kleine Abweichung bei mir gab.

    Bei der Installation der Treiber sucht sich Windows einen Wolf, um den alten Treiber wieder zu finden. Wenn ich ihm manuell aber den neuen Treiber (neuer Name in der bth.inf) zuweise, geht es wunderbar.

    Sobald das Fenster des Hardware-Assistenten kommt, das einen Willkommen heißt, wählt man nicht "Software automatisch installieren (empfohlen)" sondern "Software von einer Liste oder bestimmten Quelle installieren". Auf der nächsten Seite wurde mir mein Bluetooth Stick (mit neu ausgedachtem Namen) angezeigt, und die Treiber wurden problemlos installiert.

    Danke BB007!
    Ani weata neschane et haolam.
    Ani weata as jawou kwar kulam.

    Kommentar


    • #3
      Danke, hat bei mir auch super funktioniert.

      Ich habe aber auch eine Sache, die du in deiner Anleitung ergänzen könntest.
      Bei mir waren in der Reg die ID einmal mit rev und einmal ohne angegeben. Im Zweifelsfall immer die mit rev nehmen, auch nicht beide.

      also nur: usb\vid_xxxx&pid_xxxx&rev_xxxx

      Kommentar


      • #4
        Das &rev_xxxx ist eher selten und dürfte bei den wenigsten Adaptern zutreffend sein. Ich werde es aber trotzdem mit aufnehmen.

        Übrigens habe ich eben ein interessantes Feature gefunden: Die MS-BT-Software weist offensichtlich jedem gekoppelten BT-Gerät, welches mit seriellem Profil arbeitet, einen eigenen Satz von COM-Schnittstellen zu. D.h. es gibt wie bei Widcomm zwei COMs (die MS-Software nennt das "eingehende" und "ausgehende" Verbindungen, entspricht den "lokalen" und "Client" - Diensten in der Widcomm-SW), allerdings bekommt jedes Gerät separate Schnittstellen. Bei mir sieht das also z.B. so aus, daß das P900 COM5 und COM6 bekommt und ein probehalber angemeldetes T39m bekommt COM7 und COM8. Man müsste somit gleichzeitig mehrere BT-Geräte via seriellem Profil GLEICHZEITIG verwenden können, was IMHO bisher nicht ging.

        Kommentar


        • #5
          Dank deiner Anleitung hat die Installation jetzt geklappt. Nur leider kann ich weder Daten empfangen, noch senden. Die Dienste unter Eigenschaften hab ich alle aktiviert, hat aber nichts genützt. Ich bekomme bei jedem Versuch eine Datei zu senden eine Fehlermeldung, egal ob auf T610, oder PC.

          Marcel

          Kommentar


          • #6
            Komisch, das rüberschieben von einzelnen Dateien geht bei mir einwandfrei...
            Aber hat schon jemand rausgefunden, wie man auch mal mehrere Dateien auf einmal rüberschieben kann, wie das mit der Widcomm-SW geht?

            Kommentar


            • #7
              Hat irgendjemand mit nem MSI USB Bluetooth Adapter diesem mit BBs Methode zum laufen bekommen?! Ich bekomme das nicht hin...

              Edit: Ganz klarer Fall von ....
              Wie schon erwähnt hatte auch ich nicht die Device ID mit dem "...xxxREVXXX.." Anhängsel verwendet... in der Registry hab ich diese dann gefunden und damit klappts auch... nun bin ich am rumprobieren wie ich damit synce...
              Es wird einem nie Langweilig!
              Zuletzt geändert von Der_Mond; 10.04.2004, 00:31.
              PARTOS meint: Es gibt ein Problem mit dem Request aufgetreten

              Kommentar


              • #8
                Ich benutze den Acer BT Dongle unter XP und habe folgendes Problem:
                Mit der mitgelieferten Widcom Software kann ich ohne Probleme Daten zum Handy senden und auch synchronisieren nur leider kann ich keine serielle Anschlussverknüpfung erstellen. Bei mir ist im Setup Port 0 eingestellt was sich auch nicht ändern lässt. Wenn ich nur eine Verbindung aufstellen möchte sagt er immer ie Serial Port 1-Verbindung ist fehlgeschlagen:Unbekannter Anschluss.
                Woran kann das wohl liegen?
                Wenn ich diese Anleitung hier im Thread befolge würde es dann funktionieren?
                Also mir dieses SP2 runterlade?
                *Leb dein Leben*
                ICQ: 235184344
                ------> Gruß Dominik

                Kommentar


                • #9
                  Hat bei mir soweit auch funktioniert, allerdings kann ich nicht auf den Ordner Gallary im Handy zugreifen...

                  Hat schon jemand eine Lösung dafür? Empfangen geht (wird als Mitteilung angezeigt)

                  Kommentar


                  • #10
                    Original geschrieben von BigBlue007
                    [...]

                    Man müsste somit gleichzeitig mehrere BT-Geräte via seriellem Profil GLEICHZEITIG verwenden können, was IMHO bisher nicht ging.
                    Ich habe eben getestet: Ein Nokia N-Gage mit der speziellen Nokia N-Gage Suite und ein Nokia 6230 mit PC Suite 6.0 waren gleichzeitig verbunden!
                    Danke Billy, ich küsse deine Füsse! endlich ein gut einsetzbares Bluetooth, viel besser als die alte Widcomm Zahnprotese.

                    Viele Grüße
                    Thomas

                    Kommentar


                    • #11
                      Musste das SP2 bei mir leider wieder runterwerfen, weil es nach der Installation nicht mehr möglich ist, mit AVMs Fritz!Fax zu faxen.

                      Da heißt es dann wohl nun leider auch für mich, auf die finale Version zu warten.

                      Kommentar


                      • #12
                        hi, also erst mal vielen dank für diese anleitung. sehr cool! scheint auch auf jeden fall besser zu gehen als bisher.

                        aber nun hätte ich noch eine super-dau-frage:

                        man kann nicht ohne die nokia suite auf das handy zugreifen und sozusagen "browsen" wie beim phone manager?

                        ich würde den am liebsten nämlich gar nicht installieren, da gerade das erste mal bt gut läuft.

                        aber wenn ich das nach der methode oben mache und dann etwas über kontextmenü auf das handy schiebe, kommt es automatisch immer aufs handy und nicht auf die mmc...

                        oder habe ich eine option übersehen?

                        widcomm und nsuite habe ich gerade beides nicht drauf.
                        Super Wallpapers für Euer 6230.

                        -->HIER<--

                        Kommentar


                        • #13
                          tja was bringt mir das ganze ohne unterstützung des headset profils??????


                          ich will wieder meine widcomm sw. lauffähig bekommen aber scheinbar bin ich zu blöd hierfür ;-(

                          Kommentar


                          • #14
                            Original geschrieben von Zero7
                            hi, also erst mal vielen dank für diese anleitung. sehr cool! scheint auch auf jeden fall besser zu gehen als bisher.

                            aber nun hätte ich noch eine super-dau-frage:

                            man kann nicht ohne die nokia suite auf das handy zugreifen und sozusagen "browsen" wie beim phone manager?

                            ich würde den am liebsten nämlich gar nicht installieren, da gerade das erste mal bt gut läuft.

                            aber wenn ich das nach der methode oben mache und dann etwas über kontextmenü auf das handy schiebe, kommt es automatisch immer aufs handy und nicht auf die mmc...

                            oder habe ich eine option übersehen?

                            widcomm und nsuite habe ich gerade beides nicht drauf.
                            hallo@all!

                            schliesse mich mit meiner frage mal hier an!

                            habe auch das sp2 installiert, connect mit dem sx1 hat auch einwandfrei funktioniert ohne das ich noch irgendwelche weiteren einstellungen vornehmen musste.
                            jetzt möchte ich gerne via bluetooth über meine dsl verbindung mit dem sx1 surfen, aber OHNE die sx1 data suit zu installieren. wie bekomme ich denn das hin?
                            windows hat mir automatisch die folgenden ports zur verfügung gestellt:

                            Dial-up Networking (DUN) COM 3
                            Serial Port (SPP) "Bluetooth Serial Port" COM 4
                            Soweit ich das verstehe müßte es doch ohne Installation des mrouters (den es ja anscheinend nur im bundle mit der data suit gibt?!) über den serial port auf meine dsl i-verbindung zu zugreifen?
                            aber leider ist das handy zwar erkannt, aber nicht verbunden und ich kann es auch irgendwie nicht dazu bringen. sonst habe ich es immer durch setzen des häkchens im mrouter connected...

                            jemand ne idee?

                            EDIT im sx1 ist der rechner erkannt und verbunden (EDIT 2 wohl eher nicht verbunden ) und zudem jede verbindung ohne bestätigung authorisiert....dennoch nichts. hab es wie zuvor mit opera und netfront probier, indem ich eine seite aufrufe und ihm dann bei der verbindungsabfrage meine opera verbindung (gprs profil ohne zugangspunkt oder sonstige angaben) gebe. bei opera passiert nichts und netfront meckert über einen fehlenden dns server. sonst ging das immer ohne probleme, indem er kurz versucht hat gprs zu aktivieren und dann auf die bestehende bluetooth verbindung ausgewichen ist....

                            thanx&greetz

                            JohnnyT
                            Zuletzt geändert von johnnyt; 04.06.2004, 08:45.
                            alle Infos zu VoIP: IP-Phone-Forum.de

                            Kommentar


                            • #15
                              hmm .. ich hab da auch noch ne frage .. also mein acer dongle wurde problemlos von winxp erkannt und des sp2 hat des auch problemlos installiert ...

                              nur mit der synchronisation zwischen pcsuite und dem windows bluetooth programm harkts .. ports sind gleich .. wenn ich zB rechtsklick und per "senden an" sachen sende gehts des ohne probs .. nur von handy zu pc geht nicht und halt auch die pcsuite und der mrouter erkennen die verbindung nicht an .. das nervt weil man halt hin und wieder auch seine geschossenen schnappschüsse aufm rechner begutachten will ..

                              wär super wenn da jemand was wissen würde ..

                              Greetz

                              Kommentar

                              Skyscraper

                              Einklappen
                              Lädt...
                              X